TankMate
Search…
Using BluConnect
Connect your TankMate sensor to a WiFi network (v2 / R3)
Your phone must have Bluetooth turned ON, as well as Location Services!
To edit the WiFi connection of an existing sensor:
  • In the TankMate mobile app, go to Settings > Sensor / Tank Settings
  • Select "Edit Network Settings" - from the Sensor Settings section
  • Make sure your sensor is in the correct mode for BluConnect - see details for v2 sensors here, or R3 sensors here
  • On the BluConnect screen - press the button to "Scan for a TankMate Sensor"
TIPS:
  • You do NOT need to search for, or pair the sensor as a bluetooth device outside of the TankMate app. It must be done from within the app, on the BluConnect screen. If you have paired the sensor on your phone's Bluetooth devices screen - unpair / forget the device before continuing.
  • If you are having difficulty finding the sensor - turn Bluetooth (on your phone settings) OFF and then back ON. Further troubleshooting tips below.
  • The sensor should be within a few metres of your mobile phone - to ensure the temporary bluetooth connection is in range
  • iPads can have issues with this process! Use a mobile phone instead.
A sensor ID will be displayed under the button. Select this to continue.
On the next screen:
  • select the name of your WiFi network and enter the password
  • Ensure the sensor is still blinking (Blue or Purple, depending on model)
  • Press "CONFIRM" to send your network details to the sensor
If you can't see any SSID options listed, check the following:
  1. 1.
    You are connected to the target WiFi network
  2. 2.
    You have enabled Location services for the TankMate app. See here for details
A success message should be displayed in the app after 5-10 seconds. The LED on the sensor will turn a solid light blue (cyan) colour for 5-10 seconds after a successful connection.

Troubleshooting BluConnect

Error Messages after sending your SSID / password

  • Incorrect password - check your WiFi network password
  • Network error. TankMate sensors can only connect to 2.4GHz networks. Combined 2.4 / 5GHz networks are also supported. Check your network details. Further WiFi tips can be found here.

I cannot see any device listed when I scan using the BluConnect screen

  • Ensure Bluetooth is turned on. If it is, try turn Bluetooth OFF and then back ON. Exit the BluConnect screen and come back in if the issue persists.
  • Check that location services are turned on
  • Don't use an iPad! These are not always compatible with our Bluetooth (BLE) protocols
  • Make sure you are close to the sensor (1-3 metres)
  • Check that the sensor is in the correct mode for BluConnect - see details for v2 sensors here, or R3 sensors here

The app is stuck spinning after I send the SSID / password

  • Check that you are close to the sensor while completing this process. The temporary Blutooth connection only has a range of a few metres
  • Ensure the sensor is still blinking (Blue or Purple, depending on model) when the network details are sent to the phone. If not - press the RESET button once (to wake it up) before pressing "CONFIRM".